Latest Diablo 3 News
DiabloWiki Updates

This site is so unbelievably, rage-inducingly slow.

Discussion in 'Feedback, Suggestions & Support' started by JimmahDean, Mar 28, 2013. | Replies: 7 | Views: 3864

  1. JimmahDean

    JimmahDean IncGamers Member

    Joined:
    Mar 28, 2013
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    I try to view a thread to reply to it, and it either goes instantly, or it takes 20 minutes to load. In the meantime, reddit, youtube, and pandora work just fine and dandy, while I'm sitting here ready to beat my keyboard into its bare circuits because I can't reply to my thread because either I can't go to the reply page, or I can't even read what someone said. I know it's not the site, because my brother accesses it just fine from a quarter mile away from me, and it's not my connection. So what's up?
  2. Solomon Wreath

    Solomon Wreath Banned

    Joined:
    Aug 1, 2011
    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    0
    it's all the damn ads and banners. they're the bane of internet connection. the SEScoops is even worse
  3. Elly

    Elly Administrator

    Joined:
    Feb 22, 1997
    Messages:
    4,450
    Likes Received:
    20
    Trophy Points:
    472

    As you say, it's not the site so because your brother can access it fine so I'm not sure I'm the person to help you. Do you take another route to the server than your brother? Perhaps you have different settings on your browser.
  4. nulio

    nulio IncGamers Member

    Joined:
    Jun 7, 2009
    Messages:
    3,247
    Likes Received:
    4
    Trophy Points:
    256
    I'm having some issues too.

    Sometimes when I click 'Post quick reply' the site asks if I want to leave or stay in the page, like I'm closing it.

    Some new posts on threads I subscribe doesn't show on the subscriptions (it complete ignores colony's last post here: http://diablo.incgamers.com/forums/showthread.php?760054-The-PvP-Thread&p=8515150#post8515150 ).

    I was replying to this thread, it doesn't show my answer and when I try again it says it's a duplicate post:
    http://diablo.incgamers.com/forums/...S-Iso-Frostmaiden-stuff&p=8515383#post8515383

    Cheers
  5. zaphodbrx

    zaphodbrx IncGamers Member

    Joined:
    Nov 1, 2011
    Messages:
    3,689
    Likes Received:
    0
    Trophy Points:
    466
    Yeah, agree on above.
    A bunch of posts have disappeared/ doesn't look right.
  6. Elly

    Elly Administrator

    Joined:
    Feb 22, 1997
    Messages:
    4,450
    Likes Received:
    20
    Trophy Points:
    472
    Rush has been doing some maintenance today so the forums would have been up and down as he applied changes.
  7. zaphodbrx

    zaphodbrx IncGamers Member

    Joined:
    Nov 1, 2011
    Messages:
    3,689
    Likes Received:
    0
    Trophy Points:
    466
    Can anyone take a look at this thread

    It seems to be screwed..
  8. Black Lotus

    Black Lotus IncGamers Member

    Joined:
    Feb 19, 2010
    Messages:
    1,155
    Likes Received:
    0
    Trophy Points:
    120
    I've just turned Adblock off for a minute and yes, this forum's pages load 2~5 times slower without adblock on, depending on page. I must say that wasnt the case until recent (2013s) updates, as described in my thread http://diablo.incgamers.com/forums/showthread.php?844072-Destiny-advertisement&highlight= , when advertisement became somewhat unbearable. That time, it was fixed few days after I've started the topic.

    Anyway, load time is still seconds, maybe a few dozens, but certainly no 20 minutes or something.

Share This Page