Latest Diablo 3 News
DiabloWiki Updates
Support the site! Become a Diablo: IncGamers PAL - Remove ads and more!

I'm having high ping issues with Diablo 2, out of ideas. Anyone know a fix?

Discussion in 'Diablo 2 Community Forum' started by Ten, Apr 3, 2013. | Replies: 1 | Views: 1815

  1. Ten

    Ten IncGamers Member

    Joined:
    Apr 3, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I just reinstalled my beloved D2. I installed the glide wrapper and disabled desktop composition. I started to play online and my ping was sitting steady at about 700. My ping stays at 700 no matter what realm I'm on. On single player I have no issues, and I run the game at about 860 FPS. I have no issues with other games. I run Starcraft 2 and Battlefield 3 on Ultra graphics with zero lag. My internet is up to 12 mbps, and at it's lowest is 4 mbps. So that isn't an issue. I use to run Diablo 2 on 50 kb/s dial-up with no issues back in the day.

    There is an annoying delay between when I click on an item, and when I interact with it. Makes playing the game intolerable. If anyone has any ideas for a fix I'm all ears.

    Here's some of my system specs if that helps.

    Windows 7 professional
    Nvidia Evga 550Ti
    Intel i5 quad core
    16gb ddr3 Gskill ripjaws
  2. Pyrotechnician

    Pyrotechnician IncGamers Site Pal

    Joined:
    Apr 21, 2011
    Messages:
    6,521
    Likes Received:
    31
    Trophy Points:
    169
    Have you tried running it in compatability mode? It usually works best with Windows XP Service Pack 2, you can give that a shot.

Share This Page