Latest Diablo 3 News
DiabloWiki Updates
Support the site! Become a Diablo: IncGamers PAL - Remove ads and more!

FPS drop after extended play

Discussion in 'Diablo 2 Community Forum' started by Vultrex, Apr 11, 2013. | Replies: 4 | Views: 2364

  1. Vultrex

    Vultrex IncGamers Member

    Joined:
    Apr 11, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My relevant computer specs are :
    Processor : Intel Core i5-3350P 3.10ghz
    RAM : 8gb
    64-bit Windows 7
    NVIDIA GeForce GT 620

    I have version 1.13c with LOD and I am using PlugY.

    The Issue : Only the last two computers Ive had, I was able to run this exact game version with plugY, on a vista and a windows XP. Both had no problems in single player or multiplayer, though the vista needed some compatibility settings, and then it worked fine. But, basically, after extended time of playing on LAN mode (I like the higher FPS, and me and my friend play on Tunngle) the game starts get massive FPS drop when there are crowds of enemies, this starts to happen after about 20-30 mins of playing, and so far has only happened on LAN. This does not happen for my friend who is currently running windows XP. It also gets worse as time passes on, lagging even when not battling enemies til I just have to save and quit and restart PlugY.

    I have currently tried :
    -Changed both PlugY and diablo2.exe to run with windows xp SP2 compatabilty
    -disabled desktop composition, run as administrator,
    -tried all three graphic modes (downloaded a glide wrapper),
    -and tried all three windowed, and all three fullscreen, with the 3dfx thing in the shortcut while windowed, and without.
    I also stopped the "Windows media sharing" service, and I have no idea what else could be causing this issue. It gets impossible to play, and it sucks having to reset when my friends playing every 30 minutes, really unfair for him. I also dont think its plugY because this is the only computer that ive had this issue.

    Anyway, what do you guys think? I tried searching and everything I tried were all the solutions ive found. Really appreciate ANY ideas guys :)
  2. Archone

    Archone IncGamers Member

    Joined:
    Nov 22, 2010
    Messages:
    7,398
    Likes Received:
    7
    Trophy Points:
    166
    PlugY is considered cheating in most cases. And this forum doesnt support it. So I cant help you there.

    Have you ran the graphics test included in the D2 installation folder?
  3. Vultrex

    Vultrex IncGamers Member

    Joined:
    Apr 11, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I tested it on LOD without PlugY and had the same results, and yes, I have to run the test everytime I switch the graphic modes, which I have already done.
  4. Sarumatix

    Sarumatix IncGamers Member

    Joined:
    Jul 28, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Don't use plug y. Have similar specs except gtx680. I too am getting the same problem of slowly decreasing fps to the point of unplayable. I suspect it Is related to current nvidia drivers as I haven't had this problem in this past.
  5. Sarumatix

    Sarumatix IncGamers Member

    Joined:
    Jul 28, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Just wanted to bump this. I'm still getting this badly after 20-30 minutes it goes from 600fps to 20fps. It is really noticeable if i'm playing with something like a poison creeper druid and hurricane. The lag increase seems to be connected to the same skills that people complain lag battlenet. I haven't been able to find any other references to this bug or any solutions.

Share This Page