Latest Diablo 3 News
DiabloWiki Updates

Diablo 2 Lag Spikes Resolved once and for all

Discussion in 'Diablo 2 Community Forum' started by Mogwuy, Jun 29, 2013. | Replies: 0 | Views: 2439

  1. Mogwuy

    Mogwuy IncGamers Member

    Joined:
    Jun 28, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Alright I know there are a few threads on here in regards to this issue however they fail to mention a few things, so I figured I would create this thread to end the frustrations of getting Diablo 2 to work on new machines.

    My machine specs:

    OS: Win 7 64bit Professional
    Memory: 32Gb
    Graphics Cards: 2x Nvidia GTX 660 (3gb video memory each)

    Should easily run this game right? That's what I thought, unfortunately there are compatibility issues. So you will need to do the following things as mentioned in other numerous threads:

    On your Diablo 2 exe or shortcut to Diablo 2 shortcut right click and go to the compatibility tab:

    Run the program in compatibility with Windows XP SP3 and tick the following options:

    -Run in 256 colors
    -Disable Visual Themese
    -Disable Desktop Composition
    -Run with Admin Privileges (probably not too necessary but I do it anyway)

    If you launch after doing this you should be able to launch the game and play. However, while this fixed it for alot of people others, such as myself experience LAG spikes while playing.

    To help this issue alittle more there is a patch you can download from Blizzard to update the game with the latest version, for some that also fixed issue. However still I had Lag spikes.

    So at this point the game ran smooth but I would still hit major lag spikes. So I did some more searching, and found one more utility that some say help, which is this utility that tricks the game into thinking you are using a video card with glide effect. You can google (sorry I'm not providing links at the moment, but will do later if requested).

    Again that utility fixed it for some, but I still had lag spikes. So the next suggestion was to upgrade the video card drivers (which I probably didn't need to do, but did anyway just to see). Though some reported this fixed there issues. But not me I still had lag spikes.

    So finally, after I updated my drivers I decided to open up my Nvidia console. I found the section to manage my 3d settings. I figured out I could modify my 3d settings per game. So I found Diablo 2 in the list of games I had installed and turned off all the 3D settings, dropped every other setting as low as I could and disabled all the CUDA GPUs. ANd that was what finally fixed my lag issues.


    Update:

    After awhile of playing, the lag spikes came back in full force. When this happened I uninstalled Diablo and reinstalled completely. I had to run in compatibility mode again with XP SP3, but I didn't have to dumb down my graphics card like I did previously. I then only updated to version 1.12a and the lag this time appears to be fixed for good.

    When I did this on the laptop for the wife I found she couldn't maximize the window for the game. I had to reinstall the 3dglidefx patch and then had to mess with the resolution to get it to the size the wife wanted.
    Last edited: Jun 30, 2013

Share This Page