Latest Diablo 3 News
DiabloWiki Updates
Results 1 to 10 of 10
  1. #1
    IncGamers Member Monzee's Avatar
    Join Date
    Feb 2006
    Location
    Denmark
    Posts
    592

    Need help downgrading from 1.12 to 1.09 patch

    Is there any possible way to do this? I downloaded the patch but it wouldn't install it and gave me an error. Please help if you can




  2. #2
    IncGamers Member LD50's Avatar
    Join Date
    May 2004
    Location
    Finland
    Posts
    805

    Re: Need help downgrading from 1.12 to 1.09 patch

    You need to do a new install, and patch that to the version you want. You can find older patches here.




  3. #3
    IncGamers Member
    Join Date
    Nov 2004
    Posts
    333

    Re: Need help downgrading from 1.12 to 1.09 patch

    I thought you could rename the game.exe or something and trick an older patch into applying?

    or was that starcraft?

    There is also Trenshadow? something like that version switcher that works with a patched game. I only tried it during 1.11 though.

    I prefer separate folder structures in the end, but that is easiest to do from an unpatched install.




  4. #4
    IncGamers Member Corrupted's Avatar
    Join Date
    Jul 2004
    Location
    1.13
    Posts
    2,687

    Re: Need help downgrading from 1.12 to 1.09 patch

    I think if you get the game.exe from Blizzard's ftp and throw it in your d2 dir you can apply any patch you want. I'm not 100% though




  5. #5
    IncGamers Member
    Join Date
    May 2008
    Location
    France
    Posts
    27

    Re: Need help downgrading from 1.12 to 1.09 patch

    Quote Originally Posted by Corrupted View Post
    I think if you get the game.exe from Blizzard's ftp and throw it in your d2 dir you can apply any patch you want. I'm not 100% though
    I confirm, here are the files from Blizzard's ftp :

    This one for Diablo II Classic

    And that one for Lord of Destruction.



  6. #6
    IncGamers Member nebux's Avatar
    Join Date
    Oct 2005
    Location
    1.13c fam fts sc
    Posts
    3,456

    Re: Need help downgrading from 1.12 to 1.09 patch

    trenshadow version switcher is the best




  7. #7
    IncGamers Member Baconated's Avatar
    Join Date
    Sep 2011
    Posts
    79

    Re: Need help downgrading from 1.12 to 1.09 patch

    Necro thread here.. but is Trenshadow allowed here? Is it still working/available?



  8. #8
    IncGamers Member jjscud's Avatar
    Join Date
    Aug 2004
    Location
    Happy Valley
    Posts
    3,531

    Re: Need help downgrading from 1.12 to 1.09 patch

    Its definitely allowed as it doesn't alter the game in any way. It simply manages different installs for you.

    I know its still used, but someone else will have better info on the wheres and hows.




  9. #9
    IncGamers Member Baconated's Avatar
    Join Date
    Sep 2011
    Posts
    79

    Re: Need help downgrading from 1.12 to 1.09 patch

    Thanks Jj



  10. #10
    IncGamers Member cheerupemokid10's Avatar
    Join Date
    Nov 2003
    Location
    Illinois
    BattleTag pizzle-1873
    Posts
    444

    Re: Need help downgrading from 1.12 to 1.09 patch

    if you search for trenshadow (hopefully definitive version 1.0) there should be a guide. I think it's also stickied under the "different sp versions" section in the forum guide. Pretty straightforward to install but you may have to update to 1.13 to be able to run the switcher correctly rather than have 1.12 as your base folder.

    Welcome to the 1.09 club! Check out the 1.09 thread that RobbyD and I keep up on for just a little bit of everything about 1.09. He's also got a great guide stickied in that sp versions section of the forum guide.

    As a matter of fact, I just noticed the thread has been bumped and is momentarily on the first page of the SPF.



    Last edited by cheerupemokid10; 10-11-2011 at 16:14. Reason: added thread note

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •